Contact Us
If you need help, we'd love to hear from you.
Please read the support page for your product before writing to us.
If you are unable to use this form, or need to send an attachment, please e-mail to:

MAR 19, 2019 - EARTHDESK
We recently received confirmation that the satellite service that has been providing our cloud images since 2003 will be closing on March 31. We have been anticipating this for several months and are in the final stages of switching to a new provider. We hope that the overall quality of the cloud images will improve as a result of this process. The switch is now in place for standard clouds and should switch for data subscriptions next week. EarthDesk will automatically handle the switch with no action required.

EarthDesk 6.8 is the minimum version required for cloud images. Earlier versions may display a milky film or checkerboard pattern over the entire map. For the Mac version of EarthDesk 6, please update by clicking on the "Check for Update" button in the General Tab of the EarthDesk System Preferences pane.

Enter the six characters shown below.